Install Gnome Shell Themes with the User Theme Extension and Gnome Tweak Tool ~ Ubuntu 11.10

  • Once again, installing Gnome Shell themes has changed a tad.  Below are the instructions for installing Gnome Shell theme in Ubuntu 11.10.

    Installation

    1. If you don’t have it already, install the Gnome Tweak Tool:

    sudo apt-get install gnome-tweak-tool

    2. Install the User-Theme GNOME Shell extension from PPA.

    sudo add-apt-repository ppa:ferramroberto/gnome3
    sudo apt-get update
    sudo apt-get install gnome-shell-extensions-user-theme

    3. Once both of the above are installed, restart Gnome Shell. Either hit Alt+F2 and run r, or log out and log back in.

    4. Open the Gnome Tweak Tool. Under Shell extensions, make sure the User Themes Extension is toggled on.

    5. Under Themes, browse for a theme you downloaded*.

    *Note: You can download Gnome Shell themes here.

    6. Choose your theme from the dropdown menu.

    Share

    November 14th, 2011 | Joe Steiger | 22 Comments | Tags: , , , , , , , , , , , ,

About The Author

Joe Steiger

The owner and chief editor of JoeSteiger.com. Ubuntu user, android fanatic, tech enthusiast, Baltimore Ravens fan,...

  • Jamadeus86

    i need help i don’t get the theme section to chose themes

  • Jamadeus86

    it does not show

  • I’m confused by which part isn’t showing for you.

  • Hm. I’m doing all of the above but I keep getting a message in gnome tweak that it is an invalid theme (I was trying to install this one >> http://www.gnome-shell.deviantart.com/gallery/?set=28081982&offset=24#/d47vmgg )

  • which is the version of gnome-tweak-tool you used? i’m using 3.2.0, installed ‘gnome-shell-extensions-user-theme’ from the ppa you said, and ‘Shell Extensions’ tag is still empty – what is causing this? is this why gnome-tweak-tool is being completelly useless for me? this is really weird… :|

  • should i upgrade to Ubuntu 12.04 for having gnome-tweak-tool working?

  • User theme extension doesn’t work yet with Gnome Shell 3.2

  •  thanks a lot for the feedback, but what should i do so? is there any more recent gnome-tweak-tool .deb from any ppa?

  • It’s not really a Gnome Tweak Tool issue.  The person who made the User Theme Extension needs to update it for Gnome Shell 3.2.  That’s what you are waiting on.

  • but my huge confusion is why is this working fine on you, and maybe on everyone else as well, and not on me – what should i do for fixing what i have now? (well, btw, i hope i don’t need to go into configure/make/makeinstall… :| ) – if you can, please share some kind of tutorial about, or share some useful links about – thanks again

  • hmm, I just checked the system if believe I used for this tutorial.  I am running Gnome Shell 3.2.  I thought it was 3.0.

    1. Mark for complete removal that Gnome Tweak Tool.  Install version 3.2.0.

    2. Try installing the user theme extension with:

    sudo add-apt-repository ppa:webupd8team/gnome3
    sudo apt-get update
    sudo apt-get install gnome-shell-extensions-user-themeLet me know.

  • Did the step 1a. Step 1b i only found version 3.2.2-2 at Menu:Package:ForceVersion from Synaptic. When doing the step 2, entered successfully the first two command lines, and from the 3rd one i got this: http://pastebin.com/vKXqh1aQ (there are no broken packages from Synaptic Filter, it seems to be about broken dependencies, but i dont’ know which are these dependencies versions, and which packages exactly, and where from should i get it (ubuntu official repository or ppa, maybe doing ‘sudo dpkg -i’ on them) ) – i really don’t know what to do… :|

  •  when tried to install 3.2.2-2 of gnome-tweak-tool – i got this from Synaptic: “E: Unable to correct problems, you have held broken packages.
    E: Unable to lock the download directory”

  • Did you try what I said above?

    sudo add-apt-repository ppa:webupd8team/gnome3
    sudo apt-get update
    sudo apt-get install gnome-shell-extensions-common
    sudo apt-get install gnome-shell-extensions-user-theme

  •  yes, i tried again and again – and still nothing working…   :| –  http://pastebin.com/iGwALfZZ

  •  after all attempts i have:
    – gnome-shell-extensions-common – 3.2.0-2~webupd8~oneiric
    – gnome-shell-extensions-user-theme – 3.2.0-2~webupd8~oneiric
    – gnome-tweak-tool – 3.2.2-2

    i can’t have gnome-tweak-tool in version older than 3.2.2-2 – from https://launchpad.net/ubuntu/precise/i386/gnome-tweak-tool/3.2.0-0ubuntu1 i tried to open it with gdebi-gtk, tried to download it and do ‘sudo dpkg -i’, and nothing… – http://imageshack.us/photo/my-images/826/screenshotat20120211182.png/http://imageshack.us/photo/my-images/535/screenshotat20120211182.png/http://imageshack.us/photo/my-images/210/screenshotat20120211182.png/

  • I am out of ideas. :(  Something must be wrong with your system.  Try ubuntuforums.org

  • thanks and nevermind for now, because in the meanwhile i found from a forum post somewhere that we could paste a theme content into ~/.config/gtk-3.0 – it finally work, and only this way (gnome-tweak-tool remains not working in the same way) – the goal i could get is i finally get completely rid from that ugly default gray theme, and i made this: http://gnome-look.org/content/show.php?content=148882 – ( i were a huge gnome-color-chooser fan from the gtk2 time, and missing it on gtk3 – but anyway, it is working fine on me, i have no idea how fine it will work on themes chosen from gnome-tweak-tool , since i’m a gtk3 theming newbie)

  • Sorry I couldn’t help.

  • Sadi789

    I’m getting this message too. I’ve tried multiple themes, some of which don’t even show up when I go to open them, and some of which I click only to be shown the message “invalid theme”

  • It is probably a compatibility issue with the version of gnome you are using. Alot of the time themes don’t get upgraded. Try another method http://worldofgnome.org/install-gnome-shell-themes-in-less-than-2-live-demo/